Roland Juno G woes

Discussions about Guitars, Bass, Drums, Keyboards, Percussion, Orchestral Instruments, etc.

Moderator: Arny

Roland Juno G woes

Postby yankee44 » Sun Nov 25, 2012 9:31 pm

After years of never having any problems with my little guy, all of a sudden the orange LED display goes all wonky.

All my research points to these possible problems:
    A ribbon cable delaminating, and the associated grounding/bridging issues;
    the ribbon connector (or one of the contact points therein) working loose; or
    A cheaply made LED display, which would have crapped out on me sooner or later.

Having absolutely NO tools for diagnosing (not even my old Radio Shack voltmeter... :cry: ), I'm SOL.
Is there any way I can get a video feed from the USB out to my laptop, so that I can finish my session?
yankee44
Intern
 
Posts: 12
Joined: Tue Jul 06, 2010 11:24 pm

Re: Roland Juno G woes

Postby dbbubba » Sun Nov 25, 2012 11:07 pm

Why won't the supplied programmin software work?
I found this roland info:
http://cms.rolandus.com/assets/media/pdf/JGWS02.pdf

If you want to dig into the little bugger then I would look at the connector that you are describing, but I would also make sure that the connections of the ground planes on the various (or single) circuit boards are still intact.
I have seen several digital devices that failed or operated very erratically because the ground reference was lost.
On each of these devices the ground reference was derived by a set of screws that connected the circuit board(s) to the frame of the device.
The resistance found at the connection at the screws had allowed the ground reference to change.
In many digital devices there is a lot of processing going on at a 5 volt level.
When the ground reference is compromised the required 5 volts can sag quite easily.
Once the expected 5 volt level falls very far the device fails, but as the voltage sags below 5 volts the operation can become very erratic.

I can say that this is your problem, but I have seen the loss of the ground reference cause a lot of problems.
In most all cases simply tightening the screws that provided the circuit board's connection to ground fixed the problem.
In a few cases, like with a Yamaha 01V, I ran an extra ground strap to make sure that when the screws became loose there was still and adequate connection to ground.

Good luck!
Danny Brown
(I was going call myself Mr. B because I like people to say "MISTER" when they say my name, but then I pitied the fools.)
User avatar
dbbubba
Producer
 
Posts: 774
Joined: Tue Sep 29, 2009 8:44 pm
Location: Rockwall, Texas (Dallas area)


Return to MUSICAL INSTRUMENTS

Who is online

Users browsing this forum: No registered users and 1 guest

cron